KNOWLEDGE BASE
Log In    |    Knowledge Base    |    4D Home
Tech Tip: No Edit menu after upgrading to 4D 2003
PRODUCT: 4D | VERSION: 2003.2 | PLATFORM: Mac & Win
Published On: January 22, 2004
Your current browser may not allow you to download the asset. We recommend Mozilla Firefox or Google Chrome.
Log In

Version: 2003

In the latest version of 4D 2003, you have the ability to create your own Edit menu. In previous versions, the Edit menu was created for you. Therefore, when upgrading your database to 2003 from an earlier version, you are given the option of either using the previous Edit menu or creating your own. By default, 4D will use the "Old Edit Menu Mechanism." In other words, you are using the Edit menu from the previous versions, which will still function properly in 2003. However, if you decide not to use this, you will have to rebuild the Edit menu. Until this is done, you will loose Copy, Cut, and Paste (among others) functionalities in the Custom Environment. Therefore, any user trying to use your application will be unable to utilize this menu and the keyboard shortcuts associated with it.

If you decide to rebuild your Edit menu, you can create a new menu bar in your existing database and manually copy this Edit menu to all your existing menus. You can be sure it's the original 4D Edit if "Edit" is in Italics. When the menus and their items are in Italics, this means you are using the built-in 4D menu. If you control-click on the word in the menu bar editor there should be a reference number associated. For instance, File = ":79,1" and Edit = ":79,5". Typing in these strings (ex: :79,1 ) when you add a menu or menu item will assure that you are using the 4D version. Therefore, for actions such as Copy, Cut, Paste, etc. you will also need to use their appropriate references numbers.


Here are a few popular reference numbers to be aware of:

Undo: :131,18
Cut: :131,19
Copy: :131,20
Paste: :131,21

You must then assign the correct Associated Standard Action. Be sure to place your Edit menu directly after your File menu, which should be first and also in italics. Once done, you will be able to utilize all the functions of the typical Edit menu.

Note: You can retrieve the setup and reference numbers of the original Edit menu by creating a brand new database and using it as your template.