KNOWLEDGE BASE
Log In    |    Knowledge Base    |    4D Home
Tech Tip: BBOX alert when upgrading a database to version 2004
PRODUCT: 4D | VERSION: 2004 | PLATFORM: Mac & Win
Published On: August 14, 2006
Your current browser may not allow you to download the asset. We recommend Mozilla Firefox or Google Chrome.
Log In

When upgrading an older database to version 2004, you may get the following alert

"This database used an old compatibility mode (BBOX resource) which is no longer supported"

This alert indicates that the version 2 Compatibility resources will be ignored. Those resources were stored in the BBOX resource, hence the alert. What it may affect are the following behaviors:

- ON EVENT CALL
- Mono-transactions
- Semaphores
- Autimatic flush after transaction
- Activated/deactivated call.

Keep in mind that the presence of that resource does not mean you used the V2 compatibility, since all the options above could have been set to v6. A good way to figure out what you used would be to open the database in version 2003 using Customizer Plus and check the contents of the Compatibility resource. This will indicate if any action needs to be taken.